Questions & Support for all versions of this widget: below
Info & Install instructions for: Blogger, PHP, HTML (Iframe or Javascript) versions
WordPress Widget (info and install): read on

WordPress

Suitable for WordPress 2.8 on; tested against numerous themes up to WordPress release 3.4.1.

Demo: see side bar to your right!

As our plugin includes a “get widget” link it is no longer available in the WordPress Directory; you have to download it from our site. Note: our British Embassy Finder is still in the WordPress Directory

Installation:

  • Download the widget (a zip file) to your computer
  • Use your WordPress Dashboard to upload the complete ZIP file to your server: Plugins -> add new –> upload.
  • Activate, and add it to your sidebar in the usual way.

Customising: The widget inherits the style of your WP theme and should display well on most WordPress sites without modification. The most useful custom settings
are widget title, text of button, and width.

Configure via the WordPress dashboard in the usual way. For example under WordPress 3.1: Admin Dashboard –> Appearance –> Widgets: drag the widget to the side or widget bar then click on the widget to open its configuration form.

Change Log

= 1.0.0 =
* 30 June 11: ESSENTIAL TO UPDATE BEFORE END SEPT 2011 when file used by previous versions will be withdrawn.
Speed improvements – the file used by the widget is smaller + faster rendering of country information for users .
Fixes issue for IE6 users where the browser displayed the country advice page too wide, requiring users to horizontal scroll).

= 0.9.5 =
* 25 Mar 2011 Caching introduced – so there is no need for the widget to retrieve the drop-down form for every visitor on every page. This will reduce server bandwidth usage, and the widget should be even
quicker to load. – Note: to encourage users to adopt this internet and server friendly upgrade previous versions of the widget will cease to function from 25 Sep 2011.

= 0.9.1 =
* Further fix to cope with websites that don’t allow PHP “file_get_contents”. Reversed code so “CURL” is attempted first – fixes failure to identify “file_get” has failed.

= 0.9.0 =
* Will now use “CURL” to retrieve data if “file_get contents” fails. Resolves issue of empty drop down box where a website host has turned off PHP “allow_url_fopen” functionality.
This has ONLY BEEN REPORTED ONCE – there is no need to upgrade if your widget is working.

= 0.8 =
* First published version.

Questions and Support

Please post any questions using the comment form below. Email Address is optional and is not displayed.

If you are reporting a problem with the widget, ensure you identify the platform it is used on e.g. Blogger. If you are using WordPress please make sure you are using the latest version (see change log above).